LastPass outage - 7/6/2024

Minor incident Other Services
07-06-24 07:21 AM AEST · 5 hours, 6 minutes

Updates

Resolved

LastPass has updated to say that the issue has now been resolved but they are continuing to monitor systems.

June 7, 2024 · 12:27 PM AEST
Issue

TechPath is currently aware of an issue with users not able to login to LastPass. This is related to a current LastPass outage.

Further details can be found here: https://status.lastpass.com/

June 7, 2024 · 07:21 AM AEST

← Back