Office 365 degradation

Minor incident Other Services
27-06-24 11:58 AM AEST · 19 hours, 21 minutes

Updates

Resolved

All services are now back online and have remained stable.

June 28, 2024 · 07:19 AM AEST
Monitoring

We can see the situation has improved significantly. The queues are almost gone. Microsoft has just reported: “We determined that a recent change within Azure networking infrastructure led to impact. We reverted this change and we’re monitoring our telemetry to ensure that affected services recover as expected.”

We will continue to actively monitor the situation.

June 27, 2024 · 01:28 PM AEST
Issue

Currently, we are aware of a problem affecting various Office 365 services. This issue seems to be sporadic but is affecting products like Outlook, Teams, and SharePoint.

Users might experience difficulties such as delayed mail delivery, intermittent connection interruptions, and messages failing to send.

We are actively monitoring for updates from Microsoft regarding this situation.

June 27, 2024 · 11:58 AM AEST

← Back