Microsoft 365 - Delayed Emails

Minor incident TechPath Connectivity Services QLD Services Other Services
22-05-25 04:57 PM AEST · 14 hours, 26 minutes

Updates

Resolved

Engineers have confirmed that users sending email messages through Exchange Online in the Australian region should no longer be seeing delays in regards to email delivery. Microsoft have marked the item as resolved between 6:00 pm and 7:00 pm AEST last night. Issue id: EX1079935

May 23, 2025 · 07:20 AM AEST
Issue

TechPath have identified a number of customers seeing delayed email messages sent from outlook. Users in the Australian region sending and receiving in Exchange Online may be impacted. Microsoft are aware of the issue and are investigating. This error is out of our control. At this stage, the only notifications for this update can be seen in customers admin center. Issue id: EX1079935.

May 22, 2025 · 04:57 PM AEST

← Back