Telstra Outage

Minor incident Other Services
28-10-20 02:34 PM AEST · 16 hours, 5 minutes

Updates

Resolved

All services are online this morning

November 5, 2021 · 01:24 AM AEST
Issue

There is currently an issue affecting Telstra mobile services.

Please see https://outages.telstra.com.au/ for further updates.

This outage is impacting clients 4G failovers.

November 5, 2021 · 01:24 AM AEST

← Back