Office 365 display issue

Major incident Other Services
12-05-21 07:03 AM AEST · 7 hours, 37 minutes

Updates

Resolved

Microsoft has now released a fix for the Outlook issue that was reported earlier this morning.
Users will be required to restart their application for the changes to take effect.

November 5, 2021 · 01:25 AM AEST
Issue

Microsoft is currently aware of an issue regarding the display of emails in Outlook where only partial content is visible.

In the interim, users can access their emails through outlook.office.com

November 5, 2021 · 01:25 AM AEST

← Back